Results 1 to 5 of 5

Thread: Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bug?

  1. #1
    Sharon
    Guest

    Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bug?

    Do you use WPA2-PSK AES on Windox XP and do you not broadcast your SSID?
    Can you confirm a Windows Wireless Zero Configuration bug I'm seeing?
    Once confirmed, how do we report this to the Microsoft WZC team?

    Bug: Windows Wireless Zero Configuration (WZC), using WPA2-PSK AES, grays
    out the "Network Key" field when the SSID is not broadcast. It is
    impossible to enter the network key without resorting to broadcasting your
    SSID.

    Details:
    You can't set up your WinXP Home (WPA2-PSK AES) network without
    broadcasting your SSID (at least temporarily). This is, IMHO, a bug.

    To Reproduce .....

    1. Start Fresh:
    - Remove your current WinXP Home network connection by selecting your
    network SSID and pressing the "Remove" button in the "Wireless Network
    Connection Properties" form, press OK, and reboot your WinXP Home computer.

    2. Set your router to not broadcast your SSID:
    - On your router (mine is a Linksys WRT54G), if you have not done so
    already, please turn off broadcasting of your SSID & set your "Security
    mode = WPA2 Personal" (aka "Network Authentication = WPA2-PSK"), set your
    "WPA Algorithm = AES" (aka "Data encryption = AES"), and enter your desired
    "WPA Shared Key" (aka "Network key").

    3. Try to add your WPA2-PSK/AEs network WITHOUT broacasting your SSID!
    - On WinXP Home, bring up the "Wireless Network Connection Properties" form
    and click the "Wireless Networks" tab. Since you removed your network, you
    should not see it in the "Preferred networks" box.
    - Press the "Add" button. In the "Accociation" tab of the "Wireless network
    properties" form that pops up, enter your SSID name in the "Network name
    (SSID)" field, check the box to "Connect even if this network is not
    broadcasting", and in the "Wireless network key" section, select "Network
    Authentication = WPA2-PSK" and "Data encryption = AES".
    - Notice you need to enter a "Network key" and you must "Confirm network
    key" but inexplicably, both are grayed out. You can not enter the network
    key with the SSID not broadcasting! This is the bug.

    4. To set your network up, tell your router to broadcast the SSID.

    5. Repeat step 3 above. Now you can enter your network key.

    6. Go back to your router and disable the broadcast of your SSID.

  2. #2
    LR
    Guest

    Re: Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bug?

    Sharon wrote:
    > Do you use WPA2-PSK AES on Windox XP and do you not broadcast your SSID?
    > Can you confirm a Windows Wireless Zero Configuration bug I'm seeing?
    > Once confirmed, how do we report this to the Microsoft WZC team?
    >
    > Bug: Windows Wireless Zero Configuration (WZC), using WPA2-PSK AES, grays
    > out the "Network Key" field when the SSID is not broadcast. It is
    > impossible to enter the network key without resorting to broadcasting your
    > SSID.
    >
    > Details:
    > You can't set up your WinXP Home (WPA2-PSK AES) network without
    > broadcasting your SSID (at least temporarily). This is, IMHO, a bug.
    >
    > To Reproduce .....
    >
    > 1. Start Fresh:
    > - Remove your current WinXP Home network connection by selecting your
    > network SSID and pressing the "Remove" button in the "Wireless Network
    > Connection Properties" form, press OK, and reboot your WinXP Home computer.
    >
    > 2. Set your router to not broadcast your SSID:
    > - On your router (mine is a Linksys WRT54G), if you have not done so
    > already, please turn off broadcasting of your SSID & set your "Security
    > mode = WPA2 Personal" (aka "Network Authentication = WPA2-PSK"), set your
    > "WPA Algorithm = AES" (aka "Data encryption = AES"), and enter your desired
    > "WPA Shared Key" (aka "Network key").
    >
    > 3. Try to add your WPA2-PSK/AEs network WITHOUT broacasting your SSID!
    > - On WinXP Home, bring up the "Wireless Network Connection Properties" form
    > and click the "Wireless Networks" tab. Since you removed your network, you
    > should not see it in the "Preferred networks" box.
    > - Press the "Add" button. In the "Accociation" tab of the "Wireless network
    > properties" form that pops up, enter your SSID name in the "Network name
    > (SSID)" field, check the box to "Connect even if this network is not
    > broadcasting", and in the "Wireless network key" section, select "Network
    > Authentication = WPA2-PSK" and "Data encryption = AES".
    > - Notice you need to enter a "Network key" and you must "Confirm network
    > key" but inexplicably, both are grayed out.


    Did you uncheck the "The key is provided for me automatically" box
    before switching from "Open" Network Authentication to "WPA2-PSK"?




    You can not enter the network
    > key with the SSID not broadcasting! This is the bug.
    >
    > 4. To set your network up, tell your router to broadcast the SSID.
    >
    > 5. Repeat step 3 above. Now you can enter your network key.
    >
    > 6. Go back to your router and disable the broadcast of your SSID.


  3. #3
    Sharon
    Guest

    Re: Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bug?

    On Fri, 30 May 2008 18:50:59 +0100, LR wrote:
    > Did you uncheck the "The key is provided for me automatically" box
    > before switching from "Open" Network Authentication to "WPA2-PSK"?


    Oh my! No. I did not touch that and it was checked by default.

    Silly me. I apologize. I will try it again from scratch and report back!

  4. #4
    =?Utf-8?B?c2hvcm5ieQ==?=
    Guest

    Re: Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bu

    Using Win XP Pro x86 Volume License. System installed with SP2 CD (straight
    from Microsoft), upgrade to Sp3 via 400MB upgrade package. Running on HP
    NC6400 Laptop, Core 2 Duo 2Ghz, 4GB Ram.
    ----------
    The "The key is provided for me automatically" tick box is grey, just like
    everything else.

    Everything below the "Data Encryption:" field is grey, in fact. Choosing
    WPA/WPA-PSK/WPA2/WPA2-PSK makes no difference.

    I was able to make it work by using a developer tool that un-greys fields.
    I then entered the pre-shared key. Access point connection worked.

    This was not a problem before XP SP3. I am WZC, the Aegis v3.5.3 network
    plugin, Deterministic Network Enhancer (for Cisco VPN v5.0.0.90), Network
    Monitor 3.1.

    I am noticing that the WZC service restarts a few times at startup. I have
    a feeling this all may be related to a Linksys USB 802.11N device that I
    installed recently. Although I told it I wanted to use WZC, it still
    provided its own excess baggage.

    Hopefully that provides you with enough information to re-pro this issue.

    Thanks,

    S Hornby, MCSE
    Senior Systems Engineer

    "LR" wrote:

    > Sharon wrote:
    > > Do you use WPA2-PSK AES on Windox XP and do you not broadcast your SSID?
    > > Can you confirm a Windows Wireless Zero Configuration bug I'm seeing?
    > > Once confirmed, how do we report this to the Microsoft WZC team?
    > >
    > > Bug: Windows Wireless Zero Configuration (WZC), using WPA2-PSK AES, grays
    > > out the "Network Key" field when the SSID is not broadcast. It is
    > > impossible to enter the network key without resorting to broadcasting your
    > > SSID.
    > >
    > > Details:
    > > You can't set up your WinXP Home (WPA2-PSK AES) network without
    > > broadcasting your SSID (at least temporarily). This is, IMHO, a bug.
    > >
    > > To Reproduce .....
    > >
    > > 1. Start Fresh:
    > > - Remove your current WinXP Home network connection by selecting your
    > > network SSID and pressing the "Remove" button in the "Wireless Network
    > > Connection Properties" form, press OK, and reboot your WinXP Home computer.
    > >
    > > 2. Set your router to not broadcast your SSID:
    > > - On your router (mine is a Linksys WRT54G), if you have not done so
    > > already, please turn off broadcasting of your SSID & set your "Security
    > > mode = WPA2 Personal" (aka "Network Authentication = WPA2-PSK"), set your
    > > "WPA Algorithm = AES" (aka "Data encryption = AES"), and enter your desired
    > > "WPA Shared Key" (aka "Network key").
    > >
    > > 3. Try to add your WPA2-PSK/AEs network WITHOUT broacasting your SSID!
    > > - On WinXP Home, bring up the "Wireless Network Connection Properties" form
    > > and click the "Wireless Networks" tab. Since you removed your network, you
    > > should not see it in the "Preferred networks" box.
    > > - Press the "Add" button. In the "Accociation" tab of the "Wireless network
    > > properties" form that pops up, enter your SSID name in the "Network name
    > > (SSID)" field, check the box to "Connect even if this network is not
    > > broadcasting", and in the "Wireless network key" section, select "Network
    > > Authentication = WPA2-PSK" and "Data encryption = AES".
    > > - Notice you need to enter a "Network key" and you must "Confirm network
    > > key" but inexplicably, both are grayed out.

    >
    > Did you uncheck the "The key is provided for me automatically" box
    > before switching from "Open" Network Authentication to "WPA2-PSK"?
    >
    >
    >
    >
    > You can not enter the network
    > > key with the SSID not broadcasting! This is the bug.
    > >
    > > 4. To set your network up, tell your router to broadcast the SSID.
    > >
    > > 5. Repeat step 3 above. Now you can enter your network key.
    > >
    > > 6. Go back to your router and disable the broadcast of your SSID.

    >


  5. #5
    Barb Bowman
    Guest

    Re: Can someone else reproduce this WinXP Home WPA2-PSK AES WZC bu

    have you tried resetting the stack?
    http://support.microsoft.com/kb/299357


    On Sat, 5 Jul 2008 00:33:00 -0700, shornby
    <shornby@discussions.microsoft.com> wrote:

    >Using Win XP Pro x86 Volume License. System installed with SP2 CD (straight
    >from Microsoft), upgrade to Sp3 via 400MB upgrade package. Running on HP
    >NC6400 Laptop, Core 2 Duo 2Ghz, 4GB Ram.
    >----------
    >The "The key is provided for me automatically" tick box is grey, just like
    >everything else.
    >
    >Everything below the "Data Encryption:" field is grey, in fact. Choosing
    >WPA/WPA-PSK/WPA2/WPA2-PSK makes no difference.
    >
    >I was able to make it work by using a developer tool that un-greys fields.
    >I then entered the pre-shared key. Access point connection worked.
    >
    >This was not a problem before XP SP3. I am WZC, the Aegis v3.5.3 network
    >plugin, Deterministic Network Enhancer (for Cisco VPN v5.0.0.90), Network
    >Monitor 3.1.
    >
    >I am noticing that the WZC service restarts a few times at startup. I have
    >a feeling this all may be related to a Linksys USB 802.11N device that I
    >installed recently. Although I told it I wanted to use WZC, it still
    >provided its own excess baggage.
    >
    >Hopefully that provides you with enough information to re-pro this issue.
    >
    >Thanks,
    >
    >S Hornby, MCSE
    >Senior Systems Engineer
    >
    >"LR" wrote:
    >
    >> Sharon wrote:
    >> > Do you use WPA2-PSK AES on Windox XP and do you not broadcast your SSID?
    >> > Can you confirm a Windows Wireless Zero Configuration bug I'm seeing?
    >> > Once confirmed, how do we report this to the Microsoft WZC team?
    >> >
    >> > Bug: Windows Wireless Zero Configuration (WZC), using WPA2-PSK AES, grays
    >> > out the "Network Key" field when the SSID is not broadcast. It is
    >> > impossible to enter the network key without resorting to broadcasting your
    >> > SSID.
    >> >
    >> > Details:
    >> > You can't set up your WinXP Home (WPA2-PSK AES) network without
    >> > broadcasting your SSID (at least temporarily). This is, IMHO, a bug.
    >> >
    >> > To Reproduce .....
    >> >
    >> > 1. Start Fresh:
    >> > - Remove your current WinXP Home network connection by selecting your
    >> > network SSID and pressing the "Remove" button in the "Wireless Network
    >> > Connection Properties" form, press OK, and reboot your WinXP Home computer.
    >> >
    >> > 2. Set your router to not broadcast your SSID:
    >> > - On your router (mine is a Linksys WRT54G), if you have not done so
    >> > already, please turn off broadcasting of your SSID & set your "Security
    >> > mode = WPA2 Personal" (aka "Network Authentication = WPA2-PSK"), set your
    >> > "WPA Algorithm = AES" (aka "Data encryption = AES"), and enter your desired
    >> > "WPA Shared Key" (aka "Network key").
    >> >
    >> > 3. Try to add your WPA2-PSK/AEs network WITHOUT broacasting your SSID!
    >> > - On WinXP Home, bring up the "Wireless Network Connection Properties" form
    >> > and click the "Wireless Networks" tab. Since you removed your network, you
    >> > should not see it in the "Preferred networks" box.
    >> > - Press the "Add" button. In the "Accociation" tab of the "Wireless network
    >> > properties" form that pops up, enter your SSID name in the "Network name
    >> > (SSID)" field, check the box to "Connect even if this network is not
    >> > broadcasting", and in the "Wireless network key" section, select "Network
    >> > Authentication = WPA2-PSK" and "Data encryption = AES".
    >> > - Notice you need to enter a "Network key" and you must "Confirm network
    >> > key" but inexplicably, both are grayed out.

    >>
    >> Did you uncheck the "The key is provided for me automatically" box
    >> before switching from "Open" Network Authentication to "WPA2-PSK"?
    >>
    >>
    >>
    >>
    >> You can not enter the network
    >> > key with the SSID not broadcasting! This is the bug.
    >> >
    >> > 4. To set your network up, tell your router to broadcast the SSID.
    >> >
    >> > 5. Repeat step 3 above. Now you can enter your network key.
    >> >
    >> > 6. Go back to your router and disable the broadcast of your SSID.

    >>

    --

    Barb Bowman
    MS-MVP
    http://www.microsoft.com/windowsxp/e...ts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •